Wake on LAN trouble

Topics related to the iOS and/or Apple Watch app.
Post Reply
fxwegr
Posts: 16
Joined: Wed Dec 14, 2016 3:40 pm

Wake on LAN trouble

Post by fxwegr » Wed Feb 08, 2017 12:22 pm

Hi Dave,
sorry but I need your help again, the Wake on LAN function does not work as expected.

If I run an eventrigger button executes an broadcast WOL command, I get an connection error.
Normally no IP address or port is needed to send a magic packet to a LAN adapter. So I do not understand why I get an connection error.

The interface as well as the eventtrigger button I have set up according to your instructions. The final octet of the broadcast IP is '255'. Port I have set to '0'.

What should I do?

User avatar
Dave
Site Admin
Posts: 73
Joined: Mon Dec 01, 2014 12:41 pm
Contact:

Re: Wake on LAN trouble

Post by Dave » Fri Feb 10, 2017 5:12 am

Hi. Sorry for the problems. I am not able to recreate this problem when using the documented WOL[] command using an EventTrigger button. You can get this error, however, if the WOL command is not formatted exactly as shown in the doc. It must be in the following format:

WOL[ab37c423fd76]

There cannot be a space between WOL and the opening bracket, and it must use square brackets around the MAC address. Can you verify that your WOL command follows this formatting? You could argue that the formatting could be a little more relaxed to allow for extraneous spaces, etc., but currently it is not.

Thanks.

fxwegr
Posts: 16
Joined: Wed Dec 14, 2016 3:40 pm

Re: Wake on LAN trouble

Post by fxwegr » Fri Feb 10, 2017 3:27 pm

>>There cannot be a space between WOL and the opening bracket.<<

That was the problem. Thank you for this great hint. I am very relieved, with the WOL function stands and falls my project.

User avatar
Dave
Site Admin
Posts: 73
Joined: Mon Dec 01, 2014 12:41 pm
Contact:

Re: Wake on LAN trouble

Post by Dave » Fri Feb 10, 2017 3:41 pm

Great! Glad it's working.

Post Reply